Wednesday, 2018-06-27

*** frinring_ is now known as frinring08:19
NeoChapayI found patch for gobject-introspection with fix build problem on x86_64 https://github.com/GNOME/gobject-introspection/commit/43de9fbadf1a389049cb6e67069c6c16cd0629f211:54
NeoChapayI update glib and gobject-introspection11:54
NeoChapayBUT!11:54
NeoChapaybuild fail :)11:54
r0kk3rzNeoChapay: did you make a patch? or update version11:57
NeoChapayi update version11:58
NeoChapaypatch not helped11:58
r0kk3rzif the patch didnt help then perhaps its a different issue11:58
NeoChapayyeap...11:58
*** SpeedEvil is now known as Guest6070511:59
NeoChapayi not understand why only on x86_64....11:59
r0kk3rzim going to guess, ye olde gcc12:00
locusfaarch64 works?12:04
*** BitEvil_ is now known as SpeedEvil12:06
NeoChapayyeap12:12
abransonwe don't build x64 internally, so it might be actually broken. unlike those other broken packages which are the result of some inconsistency between the jolla obs and the mer.13:59
NeoChapaysb2 build error https://build.merproject.org/package/live_build_log/home:neochapay:mer:core/sb2-tools-qt5-aarch64/latest_i486/i58614:02
abransonthat's getting some updates atm14:03
abransondoes gobject-intro need an update?14:03
NeoChapayabranson: i try update gobject-intro but no effect14:04
NeoChapayglib2 and gobject-intro14:04
pvuorelajust to note that i've had PR open for updating those two for a while now.14:13
r0kk3rzyeah im building both those updated ones, and gobject-intro doesnt build on x6414:14
NeoChapayr0kk3rz: only on x86_64 build fail on aarch64 all is well14:16
r0kk3rzyeah i think ill switch to i486 instead14:16
r0kk3rzhmm, why is obs installing llvm 3.3 and 4.0.0 and then complaining that they conflict19:22
r0kk3rz*facepalm*19:22
malr0kk3rz: some package depends on one and another depends on the other version?19:26
r0kk3rzyeah possibly19:27
r0kk3rzthat sounds annoying to unravel :)19:27
r0kk3rzah, the order in the meta is order of precendence19:30
malr0kk3rz: oh?19:30
malwhich way?19:31
r0kk3rztop is higher19:33
malI would have assumed version has higher priority than order19:34
malbut I seem to that common above the main target so that is good19:35
r0kk3rzi would have thought so too, but perhaps its a lot more efficient to choose the first one that satisfies the requirement19:39
r0kk3rzso check local > check first repo > check second repo .etc19:39

Generated by irclog2html.py 2.14.0 by Marius Gedminas - find it at mg.pov.lt!