09:00:39 <Jaymzz_> #startmeeting Sailfish OS, Open Source, Collaboration 22nd of March 2017
09:00:39 <merbot> Meeting started Wed Mar 22 09:00:39 2017 UTC.  The chair is Jaymzz_. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
09:00:39 <merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
09:00:54 <Jaymzz_> #info meeting information and agenda can be found here: https://lists.sailfishos.org/pipermail/devel/2017-March/007764.html
09:01:05 <Jaymzz_> I am the meeting's chairperson today and will be doing my best to keep time and order. Please behave, be gentle and show due respect.
09:01:12 <Jaymzz_> #info Since this meeting was going to be a longer-than-usual session, I was forced to reduce the duration of some of the topics by requests from sailors who have to do their work! In case the time was not enough, we can continue the topic during the next meeting (whenever we agree the time and date). I also have moved the two related topics to the end of the meeting by request.
09:01:44 <Jaymzz_> #topic Brief introduction (5 minutes). Please prefix your name/handle with # info
09:01:51 <Jaymzz_> #info James Noori, Community Manager, Jolla
09:02:11 <r0kk3rz> #info Lewis Rockliffe, community member
09:02:13 <veskuh> #info Vesa-Matti Hartikainen, Program Manager, Jolla
09:02:31 <Venty> #info Martin Ebnoether, Community Member and SailfishOS Fanboy
09:02:46 <occirol> #info occirol, Community member
09:02:57 <nh1402> #info nh1402, community member and a sfdroid guy
09:03:07 <tomoshokas> #info Tomoshokas, Community member
09:03:39 <locusf> #info Aleksi Suomalainen, Nemo and Sailfish Community member
09:03:40 <chriadam_> #info Chris Adams, developer at Jolla
09:03:41 <jlassila> irc://chat.freenode.net:6667/#info Juhani Lassila, Head of Communications, Jolla
09:03:50 <sledges> #info Simonas Leleiva, l10n'n'hw @ jolla
09:04:04 <libregeekingkid[> #info Raju , Community Member
09:04:06 <pketo> #info Pami Ketolainen, backend developer @�Jolla
09:04:11 <M4rtinK> #info Martin Kolman, community member and modRana developer
09:04:17 <jlassila> irc://chat.freenode.net:6667/#info Juhani Lassila, Head of Communications, Jolla
09:04:50 <eekkelund> #info eekkelund,  Maemo Community council + community member
09:05:52 <Jaymzz_> We should be more, come on guys :D
09:06:06 <ljo> #info Leif-Jöran Olsson, community
09:06:08 <ApBBB> we know eachother :P
09:06:23 <Jaymzz_> The bot should know too ;)
09:06:58 <Jaymzz_> Moving to the first topic in 30 sec
09:07:05 <Coolgeek> I'm just a regular jolla1 user, not even a dev, translation or else, so I will stay quiet :p
09:07:27 <Jaymzz_> #topic MWC Announcements Q&A (20 mins) Asked by c_la , backup: r0kk3rz
09:07:41 <Jaymzz_> #info This topic is shortened in duration as explained before. The Q&A is going to be divided into 2 sections. The first section is to answer the top questions from TJC Q&A page ( https://together.jolla.com/question/157639/jolla-sony-xperia-qa/?sort=votes&page=1 ) and second, whatever time we have left in 20 minutes, will be dedicated to community members asking their questions live. In case there were unanswered questions left, we
09:07:41 <Jaymzz_> will take this topic with us to the next meeting.
09:07:49 <Jaymzz_> #link https://together.jolla.com/question/157639/jolla-sony-xperia-qa/?sort=votes&page=1
09:07:51 <sledges> we welcome everyone, users opinion is just as important (if not the most)
09:08:06 <ApBBB> Since i was the one that started the q&a topic in tjc i'll better start with the questions
09:08:36 <Jaymzz_> ApBBB: Let's go over as many TJC questions as possible
09:08:36 <ApBBB> first and more importand. Why isn't there a Xperia X compact at the store already :P
09:08:56 <ApBBB> seriously:  The slides stated that SFOS will be supported on a range of devices. Will those devices be available from the jolla store or a user can buy (from any ventor) and then install SFOS on one.?
09:09:18 <ApBBB> Will sony give jolla access to the SW that powers its really good cameras so SFOS can fully exploit them?
09:09:34 <jlassila> Thanks for the questions!
09:09:59 <jlassila> So basically: the practical side of things, i.e. how a user gets the Xperia Sailfish device are not agreed fully yet. So unfortunately we will need to come back to this at a later stage.
09:10:13 <ApBBB> Many people were asking about Alien D support? We know the answer but better answer it here also.
09:10:18 <Jaymzz_> ApBBB: Wait for the answers first please before asking your next question. After these are answered, let me handle TJC questions so they can be logged properly :)
09:10:34 <ApBBB> ok ok. sorry
09:10:42 <jlassila> The answer for the Alien D support is yes. Simply.
09:11:16 <Jaymzz_> ApBBB: Thanks! You will get all of your answers either way ;)
09:11:35 <jlassila> @veskuh: camera
09:11:38 <veskuh> For the camera, we cannot yet promise that all the features of the camera are supported, but we are working on it and we think that we are going to get great quality pictures out of the camera.
09:12:09 <Venty> I personally would find it very cool to just walk into a store and buy a phone with SFOS on it.
09:12:09 <Jaymzz_> So let's do it like this: I'll ask the TJC questions as # info, and will paste the answeres underneath as another # info in order to log everything properly and make them easier to find/read
09:12:38 <nh1402> good idea
09:12:56 <Jaymzz_> #info First question: How do we get Xperias running Sailfish OS?
09:13:12 <Jaymzz_> #info Answer: So basically: the practical side of things, i.e. how a user gets the Xperia Sailfish device are not agreed fully yet. So unfortunately we will need to come back to this at a later stage.
09:13:32 <Jaymzz_> #info second question: Alien Dalvik support?
09:13:56 <Jaymzz_> #info Answer: Simply yes.
09:14:27 <Jaymzz_> #info Third question: Will sony give jolla access to the SW that powers its really good cameras so SFOS can fully exploit them?
09:14:44 <Jaymzz_> #info Answer: For the camera, we cannot yet promise that all the features of the camera are supported, but we are working on it and we think that we are going to get great quality pictures out of the camera.
09:15:03 <ApBBB> ok. another question was who will handle the warranty. because installing other stuff now on sony phones voids the warranty i think.
09:15:28 <Jaymzz_> For the next question, I'll pick them from TJC, after those are done, and we have time left, others can ask addiional questions
09:15:58 <Jaymzz_> Okay let's go with the warranty question first since it's asked now
09:16:00 <ApBBB> there were questions about the sony involvement in this.how much are they helping or if they just let jolla use the devices.
09:16:02 <jwalck> #info Jonatan Walck, Community member
09:16:15 <jwalck> oh, I was scrolled off. appologies!
09:16:18 <ApBBB> Jaymzz_: i copy paste from the tjc topic
09:16:26 <ApBBB> or interprate
09:16:43 <Jaymzz_> ApBBB: The goal was to let me handle that so it can get properly logged :)
09:16:53 <Jaymzz_> So if you could please let me do it, I'd be grateful!
09:17:14 <ApBBB> yes ok. no problem
09:17:22 <Jaymzz_> #info Fourth question: How will the warranty be handled?
09:17:38 <Jaymzz_> Veskuh ^
09:17:56 <jlassila> About warranty: this goes to the same category as the first one: i.e. not agreed yet.
09:18:06 <Jaymzz_> ApBBB: Thanks. This way we can be more time efficient as well :)
09:18:32 <Jaymzz_> #info Fifth question: To what extent are Sony involved?  Are they simply allowing their hardware to be ported onto, or are they looking at becoming an official partner?  In essence, in the future, could we buy a Sony device running SFOS?
09:18:55 <Jaymzz_> #info Answer to the previous question: Not agreed yet.
09:19:20 <jlassila> This is a collaboration between Jolla and Sony Open Devices Program. The future regarding "buying a Sony device with Sailfish OS" is under discussion, and will be announced when we know.
09:19:37 <Jaymzz_> #info Answer: This is a collaboration between Jolla and Sony Open Devices Program. The future regarding "buying a Sony device with Sailfish OS" is under discussion, and will be announced when we know.
09:20:29 <Jaymzz_> #info Sixth question: When can we expect the first Xperias with SFOS? I imagine it will be an official port of SFOS onto an Xperia already running Android.  If this is the case, will there be a clear, step-by-step process to help those Jolla fans who don't have great tech knowledge
09:21:26 <jlassila> We target to have something to offer at the end of Q2.
09:21:46 <Jaymzz_> #info Answer: We target to have something to offer at the end of Q2.
09:21:51 <jlassila> And yes our aim is to make it as easy as possible.
09:22:06 <Jaymzz_> #info Seventh question: Will the Dual Sim models be supported if the single sim devices are going to receive SFOS?
09:22:09 <pavi[m]> End of june?
09:22:31 <jlassila> Yes end of June.
09:22:42 <jlassila> Our first project is with the Xpreria X device, further devices are still to be agreed and announced. Aim is to support several Xpreria series devices.
09:23:07 <Jaymzz_> #info Answer: Our first project is with the Xpreria X device, further devices are still to be agreed and announced. Aim is to support several Xpreria series devices.
09:23:07 <ApBBB> kind of scary that many things aren't set to stone yet.
09:23:09 <jlassila> Xperia, sorry for not spelling right :)
09:23:28 <pavi[m]> Will it be a limited sale device. Should we be trigger ready to click on `buy now`?
09:23:33 <ApBBB> jlassila: i want an Xperia compact :P
09:23:38 <jlassila> ApBBB: it's a project.
09:23:42 <Jaymzz_> #info Eighth question: End of June?
09:23:50 <Jaymzz_> #info Answer: Yes
09:23:56 <occirol> which model of Xperia X ?
09:24:12 <veskuh> occirol: We start with Single SIM version
09:24:12 <ApBBB> Jaymzz_: there was a dual boot question
09:24:17 <Jaymzz_> #info Ninth question: Does the cooperation include Xperia tablets?
09:24:25 <veskuh> occirol: F5121
09:24:44 <Jaymzz_> ApBBB: Next Q :)
09:24:54 <ApBBB> veskuh: my kingdom for a compact :D
09:24:55 <jlassila> For tha tablet Q: Our first project is with the Xpreria X device, further devices are still to be agreed and announced.
09:25:00 <occirol> veskuh: thanks for the precision
09:25:08 <Coolgeek> Will tey be available worldwide ? only in certain part of the world ?
09:25:08 <veskuh> ApBBB: Hmm.. Is it a big kingdom ;)
09:25:14 <Jaymzz_> #info Answer: Our first project is with the Xpreria X device, further devices are still to be agreed and announced.
09:25:28 <ApBBB> veskuh: not much but is in a sunny place :P
09:25:34 <Jaymzz_> #info Tenth question: Will the devices be pure SFOS, or will they be dual boot?
09:25:49 <Jaymzz_> side note: 5 minutes left
09:26:22 <jwalck> Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?
09:26:40 <Jaymzz_> Veskuh Could you answer the dual boot question? :)
09:26:47 <pavi[m]> jwalck:  good question
09:26:50 <veskuh> Practicalities are undecided, but we are considering both options single and dual boot.
09:27:01 <ApBBB> jwalck: i'll wait TBH. I hope they will offer a ready to buy device
09:27:08 <Jaymzz_> #info Answer: Practicalities are undecided, but we are considering both options single and dual boot.
09:27:32 <Jaymzz_> #info Eleventh question: Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?
09:27:32 <Jaymzz_> Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should
09:27:32 <Jaymzz_> run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves
09:27:32 <Jaymzz_> an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android
09:27:32 <Jaymzz_> today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish
09:27:34 <Jaymzz_> and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?
09:27:38 <Jaymzz_> oh wow
09:27:41 <occirol> wow
09:27:43 <veskuh> Hah
09:27:43 <Jaymzz_> Sorry about that
09:27:45 <ApBBB> screw dual boot if you ask me. just make everything work
09:27:45 <pavi[m]> The question with fans is, should I buy the phone now or wait for sale. Will the sale be limited or not?
09:27:52 <Jaymzz_> #undo
09:27:52 <merbot> Removing item from minutes: <MeetBot.items.Info object at 0xa53eb50>
09:27:59 <Jaymzz_> #info Does this mean we should run out and buy ourselves an xperia x with android today, getting sailfish and alien dalvik on it after Q2 2017?
09:28:36 <Coolgeek> same, I would prefer to buy a ready to use Xperia phone with SFOS on it. I don't like "playing" with OS on a phone :p
09:28:36 <M4rtinK> IMHO it would be unfortunate if existing owners would be excluded
09:28:44 <c_la_phone> hi I am joining, sort of, now
09:29:17 <M4rtinK> also I can imagine places where Jolla might have issues to ship to but where people can get the device using normal distribution channels
09:29:35 <jlassila> We should have answers relatively soon, so I'd not run to a store today. Of course up to you.
09:29:50 <M4rtinK> so if possible both pre-flashed devices & installation on own device would be nice :)
09:30:03 <Jaymzz_> #info Answer: We should have answers relatively soon, so I'd not run to a store today. Of course up to you.
09:30:39 <Jaymzz_> Alright guys, time is almost up for this topic, if you have more questions, let's move them to the next meeting please, as we will hve clearer answers (hopefully) by then.
09:31:07 <jwalck> jlassila: thanks, I'll keep my happy trigger finger in check then!
09:31:10 <Jaymzz_> I'm moving to the next topic in a few seconds,
09:31:17 <c_la_phone> I would like to buy an Xperia with SFOS but also be able to install it on Xperia android phones because Xperia is sometimes discounted in brick-and-mortar stores or online
09:31:44 <Jaymzz_> #topic Update PyOtherSide in Sailfish OS (10 min) Asked by M4tinK
09:31:50 <c_la_phone> Jaymzz_: why has the discussion been shortened that much?
09:31:52 <Drummer12_> sounds good!
09:32:00 <Jaymzz_> #info The PyOtherSide library, which makes it possible to write powerful Python + QtQuick applications, is stuck on version 1.4 on Sailfish OS. This version has some serious bugs that have since been fixed in newer versions & is missing many useful features provided by newer releases.The latest PyOtherSide stable release is 1.5.1 and I've prepared a merge request for updating to this version for the Mer core pyotherside package (
09:32:00 <Jaymzz_> https://git.merproject.org/mer-core/pyotherside/merge_requests/2 ) As the PyOtherSide library keeps as stable API, has good test coverage & my testing has not uncovered any issues I think there should not be anything preventing the merge request from being merged by the Mer pyotherside package maintainer.So I'd like to formally ask for the merge request to be merged. I would also like to know how long will it approximately take for
09:32:00 <Jaymzz_> the updated package to land in Sailfish OS release, so that Python application developers can start benefiting from the bug fixes and new features
09:32:08 <Jaymzz_> #link https://git.merproject.org/mer-core/pyotherside/merge_requests/2
09:33:22 <Jaymzz_> c_la_phone: Sorry, you weren't present in the beginning. Basically it was requested by sailors who want to do their work. It would make the meeting extremely long and since we want to have clearer answers for you guys, we said that we can continue the discussion during the next meeting
09:33:50 <c_la_phone> Jaymzz_: thanks ;)
09:34:03 <Jaymzz_> c_la_phone: Most of the key TJC questions are answered. If any of you guys have more questions, you can either ask it in general discussion later on or next meeting :) Thanks for understanding
09:34:13 <Jaymzz_> Now, let's get to the next topic for real!
09:34:31 <Jaymzz_> It had a long info section so I'll give it 15 minutes instead of 10 if needed.
09:35:22 <veskuh> We don’t at the moment have an active mainteiner for the PyOtherSide
09:35:34 <Jaymzz_> #info We don’t at the moment have an active mainteiner for the PyOtherSide
09:35:42 <c_la_phone> may I suggest to keep it a sticky topic at each meeting? "updates on Xperia project" Jaymzz_
09:36:03 <veskuh> sledges: Who would be best to go through the PR ? I suppose we’d need to test bunch of store apps since thats the main usecase
09:36:34 <Jaymzz_> c_la_phone: Let's bring it back up during general discussion :) It'll clog up this topic unnecessarily :)
09:36:37 <pavi[m]> c_la_phone:  Please stick to topic, which is pyotherside.
09:37:48 <c_la_phone> Jaymzz_: pavi[m] : Alright, although I likely will be busy during general discussion
09:37:59 <sledges> veskuh: i could ping thp to have a src lookover, and maybe community could help testing store apps?
09:39:02 <veskuh> sledges: yeah that would be great, and perhaps martyone could check the harbour validator script in sdk
09:39:41 <sledges> we can contact harbour developers who have submitted .py apps
09:39:45 <pketo> I can probably pull up a list of store apps that require pyotherside
09:39:48 <sledges> pketo: would that be doable^?
09:39:56 <sledges> :D ..think alike!
09:40:45 <M4rtinK> I'm there now
09:40:48 <M4rtinK> so basically
09:40:54 <M4rtinK> can someone merge it ? :)
09:41:04 <M4rtinK> or is there something else that needs to be done ?
09:41:27 <Jaymzz_> #action pketo to check for pyotherside apps on harbour
09:42:37 <M4rtinK> is a missing maintainer an issue ? it at least seems that most Mer/Sailfish OS packages don't have one
09:44:02 <Jaymzz_> 5 minutes left
09:44:18 <veskuh> M4rtinK: Since this is 3rd party API would be good to have someone familiar with the matter to check the things discussed
09:44:26 <M4rtinK> in any case I'm standing by if any help I can provide is needed
09:44:35 <M4rtinK> veskuh: OK
09:44:57 <Jaymzz_> #info Since this is 3rd party API would be good to have someone familiar with the matter to check the things discussed
09:45:02 <veskuh> M4rtinK:  Yeah, this is good contribution and I think we should be able to get this in 2.1.2
09:45:16 <M4rtinK> veskuh: cool, that would be very welcome!
09:45:24 <Jaymzz_> #info This is good contribution and I think we should be able to get this in 2.1.2
09:45:55 <Jaymzz_> M4rtinK: I think we can move on then, do you? :)
09:46:11 <M4rtinK> Jaymzz_: sure :)
09:46:29 <Jaymzz_> Alrighty, 10 minutes was indeed enough ;) Moving on
09:46:50 <Jaymzz_> #topic Clarify and cleanup of Wiki's (20 min) Asked by pavi[m]
09:46:58 <Jaymzz_> #info We have currently 2 Wikis, one is at https://wiki.merproject.org/ and the other is at https://sailfishos.org/wiki/ . This issue concerns the visiblity of three projects SailfishOS, Mer and Nemo. The three are related to Mer but the information in the wiki is 1. Too confusing. 2. Repeated, 3. Ambiguous, 4. Written in wrong place, 5. Outdated. I hope some time is spent to discuss these issues.
09:47:09 <Jaymzz_> #link  https://wiki.merproject.org/
09:47:15 <pavi[m]> Yay I am actually here to ask my question. Ping locusf
09:47:19 <Jaymzz_> #link https://sailfishos.org/wiki/
09:47:22 <locusf> yep
09:47:35 <Jaymzz_> 20 minutes starts now! Go go
09:48:12 <pavi[m]> So please shall we have proper seperation of wikis to start with?
09:48:24 <pavi[m]> Next one is will the SFOS wiki be opened up?
09:48:36 <M4rtinK> pavi[m]: +1
09:49:47 <pavi[m]> Jaymzz:  who in Jolla would take care of wikis?
09:51:02 <Jaymzz_> pavi[m]: It's a wiki, there isn't one person who takes care of it, naturally :)
09:51:31 <Jaymzz_> Everyone contributes in their own area pavi[m]
09:51:47 <pketo> We haven't had the time to work on opening up the Sailfish OS wiki. So at the moment there is no estimate on when that would happen
09:51:51 <pavi[m]> Jaymzz:  Yes and it applies to mer wiki. Sailfish wiki is not accessible for external people.
09:52:24 <pavi[m]> pketo_:  Lot of information could be added to the SFOS wiki especially regarding app development.
09:52:24 <veskuh> Target is to open it up for community, but we haven’t had time to proceed with that, and schedule is still looking like it will not change during short term.
09:52:40 <Jaymzz_> #info Target is to open it up for community, but we haven’t had time to proceed with that, and schedule is still looking like it will not change during short term.
09:53:19 <pavi[m]> There are many apps written by community people which are opensource. All of them can be added to the existing SFOS tutorials.
09:53:42 <pavi[m]> If the wiki is opened up it makes it easy for community to contribute to those tutorial pages.
09:53:57 <M4rtinK> maybe there content & fixes could be submitted by mail or something for now ?
09:54:12 <sledges> that's how it's done for e.g. language style guides
09:54:26 <M4rtinK> eq. wiki_update@jolla.com, you send new articles as rst files or something
09:54:28 <sledges> in l10n area
09:54:29 <M4rtinK> or corrections
09:54:36 <pavi[m]> Yes veskuh  as M4rtinK  says can we atleast mail articles for inclusion?
09:55:56 <veskuh> pavi[m]: Hmm.. That’s interesting proposal. Would separate mail box be good for this or just using developer mailing list for proposals?
09:56:38 <pavi[m]> veskuh:  a seperate mail would probably not scare the newbies. I am happy with both.
09:56:39 <stephg> o/ (sorry I'm late)
09:57:23 <Jaymzz_> stephg: \o Welcome :)
09:58:26 <M4rtinK> In any case even just for error corrections it would be good
09:58:39 <pavi[m]> veskuh:  Ideal wiki contributors are documentation writers. They can help with lot of missing documentation. I hope the wiki is opened up in future soon.
09:59:06 <M4rtinK> I guess it could have some sort of review queue even once opened up
09:59:20 <M4rtinK> I would imagine wikis have functionality like that
09:59:39 <M4rtinK> but the email based solution should work right now
10:00:20 <pavi[m]> M4rtinK:  I agree
10:01:18 <Jaymzz_> on a relatively related note, we have around 5 minutes left, let's wrap this up. So, a separate email it is? :) or what?
10:01:26 <pavi[m]> locusf:  anything to add about nemo wiki?
10:01:43 <veskuh> This sounds like something we can try. I think next step would be that we agree in Jolla the responsibilites and announce in the mailin list once we have mail address and process in place.
10:01:46 <locusf> pavi: nope, since any docs related to that are more suitable for mer wiki
10:02:29 <locusf> nemo being now just a ui extension right now
10:02:34 <pavi[m]> veskuh:  thanks for that and Jaymzz  we can wrap it up. :)
10:02:40 <locusf> all middleware + core system is mer
10:03:05 <Jaymzz_> Alright! moving on in a moment pavi[m]
10:03:35 <Jaymzz_> #topic Nemo Mobile as community distribution for SailfishOS (60 min) Asked by locusf
10:03:44 <Jaymzz_> #info After giving this some thought, about what was discussed at the previous Jolla community meeting at FOSDEM, I've come up with an idea on how Nemo Mobile can make use of the open source efforts of Jolla. It would be quite useful to have mer feeding off of Fedora packages with the newest versions of stuff and co-maintaining the middleware update effort with Fedora community.But about how Fedora and Red Hat are related, I'd like
10:03:44 <Jaymzz_> to propose an extension to Oleg's idea which relates to this, so that Nemo Mobile could be to Sailfish OS what Fedora is to Red Hat. I know its an old idea I once before proposed. but now that the open source effort from SailfishOS is apparently closing in, it would make sense to have Nemo not (necessarily) with its open UX for Glacier but rather as a community based bleeding edge testing environment for SailfishOS. Which is (at
10:03:44 <Jaymzz_> least how I have understood it) like what Fedora is doing with Red Hat distribution.
10:04:00 <locusf> okay
10:04:44 <locusf> so as previously noted eg. in the PyOtherside situation, it seems that something like this would be needed in order to properly test any upstream mer changes somehow
10:04:46 <pavi[m]> Really good idea locusf  if jolla is happy with it.
10:05:33 <locusf> and I know that Jolla is really busy with just about all things MWC so I don't expect this to be possible right now
10:06:00 <locusf> but to get the discussion started and possible future roadmap for both Sailfish and Nemo
10:06:06 <chriadam_> what does this mean in practice?
10:06:33 <locusf> all adaptations which run sailfish, can run nemo as well
10:06:36 <r0kk3rz> locusf: how is this different to the ported version of sailfish, provided silica gets opened?
10:07:03 <r0kk3rz> then you have full foss sfos, and then the commercial + proprietary side
10:07:14 <locusf> so using existing devices as basis for testing environment for volunteers, the packages would be based on upstream mer
10:07:31 <locusf> r0kk3rz: there then is nothing too much different to it then
10:07:41 <locusf> nemo has just the ui components + its own apps on top
10:08:38 <locusf> also for sailfish apps, provided that they're open sourced, this would enhance community flavor of sailfish to allow some volunteers run the latest changes on their apps and provide feedback
10:09:01 <locusf> for nemo however, the middleware is same for its apps, so making this quite separate effort then
10:10:05 <locusf> nemo would, <with its own apps, provide a testing environment for changes in sailfish middleware
10:10:45 <locusf> ok I'm done for further detailing :)
10:11:44 <veskuh> There would be a lot of value for Sailfish if would be getting more early testing of major changes so we can maturize them quicker.
10:12:13 <locusf> indeed
10:12:26 <veskuh> What kind of support would be needed from Jolla?
10:13:48 <pavi[m]> Something like how Redhat supports fedora? ;)
10:14:00 <locusf> collaboration for making the switch between EA -> Nemo testing possible, although its not necessarily needed
10:14:18 <locusf> given that the adaptation layer for Jollas devices is the sameish
10:14:42 <locusf> eg. mic should make lvm images, which upstream mic doesn't support right now
10:14:49 <locusf> erm upstream -> mer:core
10:14:56 <r0kk3rz> or even pre EA, bleeding edge stuff provided that doesnt violate any NDAs .etc
10:15:04 <locusf> yes
10:15:28 <locusf> although I'm not sure how it applies to middleware stuff, it could of course
10:15:57 <nh1402> what happened to this part of the question "It would be quite useful to have mer feeding off of Fedora packages with the newest versions of stuff and co-maintaining the middleware update effort with Fedora community"
10:16:10 <locusf> yes I forgot about that :D
10:16:18 <M4rtinK> that's IMHO a very good point
10:16:46 <locusf> it wasn't originally my question, it was posed at FOSDEM meeting as a separate comment
10:17:01 <M4rtinK> couldn't the packaging efforts of Fedora and other distros be reused ?
10:17:07 <locusf> I know that mer as jolla uses it, is quite prone to being old at some point
10:17:23 <M4rtinK> what's so special about Mer packaging that it warrants all the special effort ?
10:17:28 <chriadam_> personal opinion: anything which imposes a requirement on internal packages is unlikely to work in practice (e.g., if you update some package, which results in BIC/SIC changes, and we depend on the old library internally...)
10:17:49 <locusf> so partially migrating to fedoras packages, where applicable, could it be viable?
10:18:37 <chriadam_> more generally, I guess lbt and larstiq would have input on this idea
10:19:07 * lbt pops in
10:20:09 <M4rtinK> in general it seems like a lot of works is spent on maintaining outdated versions of packages in a very small number of people
10:20:28 <M4rtinK> generally resulting in outdated, buggy and unpatched packages
10:20:45 <pavi[m]> M4rtinK:  +1
10:20:47 <veskuh> Problem with using large part of desktop distro is that they are optimized for different use cases, newer kernel, different toolchain, desktop and server usecases etc.
10:20:57 <lbt> +1
10:21:11 <Jaymzz_> #info Problem with using large part of desktop distro is that they are optimized for different use cases, newer kernel, different toolchain, desktop and server usecases etc.
10:21:13 <M4rtinK> while there is a substantially larger number of people (Fedora, etc.) maintaining the same packages, which are generally in a much better shape
10:21:17 <locusf> even with some core packages?
10:21:27 * kimmoli late
10:21:39 <lbt> I was going to say. It is worth keeping an eye on places like fedora for patches to upstream sources but I think ultimately we need maintainers to monitor their upstreams
10:21:47 <M4rtinK> veskuh: that's what I'm not sure applies anymore these days
10:22:11 <lbt> so packaging is not something we can usefully take - it's been discussed for years and never makes sense
10:22:24 <M4rtinK> at least in Fedora many of the packages are used in the Server edition, in minimal container images, on arm boards acting as servers, etc.
10:22:30 <lbt> the one thing that we can do is use it a useful bootstrap for mer packaging
10:23:09 <M4rtinK> it's hardly just a desktop centered distro these days
10:23:20 <lbt> M4rtinK: so if we differentiate between packaging and src patches then I think we have more agreement
10:23:26 <locusf> which also what you're currently doing?
10:24:11 <veskuh> M4rtinK: Yeah, situation may be changing, but like lbt says our previous experience is saying that there would be problems. In anycase examining the current situation in more details might be a big effort.
10:24:31 <lbt> mer now has a 'mirror' git repo area which continually mirrors upstream git. It would not be unreasonable to add remotes for fedora if they existed - but that would be down to mer-core maintainers to decide
10:24:44 <sledges> run a mer:next and user it as playground? then cherry pick mature+tested packages of newer versions into mer:core ?
10:24:45 <M4rtinK> actually, even though that's rather extreme, I've been wondering what's the practical difference between Fedora/CentOS with the Mer middleware and Sailfish OS/Nemo UI on top ?
10:25:22 <lbt> sledges: that is doable - one problem in the mer-core git is that our packages all use 'random' branches to build from
10:25:23 <M4rtinK> is Mer really that better & worth the effort to maintain vs productizing an existing distro a bit ?
10:25:29 <locusf> sledges: +1
10:26:17 <sledges> lbt: have one more branch! :D (mer-next)
10:26:18 <lbt> it would make a lot of sense to standardise on mer:core/master and mer:next/master if we wanted to do that
10:26:49 <lbt> ie start to use namespaced tags (which is something we've looked at recently (larstiq and I))
10:26:56 <sledges> ah ok
10:27:03 <lbt> lots of discussion needed
10:27:15 <lbt> it also allows for partners to have <partner>/master ...
10:27:26 <sledges> right ^-^
10:27:27 <lbt> nemo/master
10:27:51 <locusf> yes I figured that this issue is exceedingly nontrivial to be handled even in 60 minutes of conversation :)
10:29:00 <r0kk3rz> M4rtinK: especially since we've seen a mer/nemo ish toolchain built off Open Embedded, but anyway
10:29:06 <lbt> how about builds of mer:<feature> ?? eg mer:pyotherside_MB3311
10:29:30 <lbt> where there's a specific bug stating a specific goal of that branch
10:29:42 <lbt> eg to test x y z and get pyotherside merged into mer:core
10:30:32 <lbt> veskuh: would that be useful in other collaborative situations
10:31:18 <veskuh> lbt: I’d imagine similiar situations would be happening more often when we have more active partners.
10:31:33 <sledges> to note: OBS feature project is very useful as it underlays all existing mer-core under your specific updated package(s), without the need to branch or do millions of copypac
10:31:56 <sledges> and rebuilds them all if they depend on your package(s)
10:32:02 <lbt> *nod* ... may be ask if it is worth investing in some evaluation with the community on this specific topic (pyotherside)
10:32:10 <lbt> sledges: yes
10:32:17 <sledges> or a toolchain upgrade for that matter
10:32:26 <lbt> veskuh: that way we can be ready when that need arises
10:32:41 <jwalck> I have to drop off somewhat, but I can just concur that this indeed sounds like a path forward. Thanks for bringing it up locusf!
10:32:50 <M4rtinK> I'd like to note that package updates should be much easier to do than they are now
10:32:58 <locusf> jwalck: np :)
10:33:03 <sledges> mer:next is good idea, but runs a risk of diverging too far from mer:core, and then cherry-picking becomes nightmare
10:33:15 <M4rtinK> it's not really documented in detail anywhere
10:33:15 <lbt> sledges: mer:next is way too vague IMHO
10:33:36 <sledges> yep, too much of a playground:)
10:33:54 <lbt> I don't think we should do that again - it's OK for jolla to have a release-driven mer:devel type thing as that gateways into mer:core but it's highly managed
10:33:55 <M4rtinK> and I don't think I would be able to do all the needed things without having Fedora/RHEL packaging experience
10:34:27 <M4rtinK> not to mention that the merge request has been apparently ignored until being mentioned at a meeting
10:34:37 <lbt> M4rtinK: we have no maintainer
10:34:44 <lbt> there is no-one there to listen :/
10:34:46 <M4rtinK> I don't imagine many others willing to got through all that
10:35:06 <lbt> M4rtinK: it's a volunteer thing - if no-one volunteers it doesn't get done.
10:35:38 <M4rtinK> well, we have a simple solution for such packages in Fedora - they get orphaned & removed from the distro ;-)
10:35:46 <M4rtinK> problem solved :)
10:35:57 <lbt> M4rtinK: yes - that is something we should consider
10:36:19 <M4rtinK> but I guess the problem that the maintainer basically has to be a Jolla employee ?
10:36:25 <lbt> we at least have a Maintainer system now - it's growing
10:36:56 <M4rtinK> & AFAIK not documented anywhere in the contribution docs on sailfish os wiki ;-)
10:36:58 <lbt> no - but they do have to talk to the other Maintainers and jolla obviously employ a  lot of them
10:37:34 <M4rtinK> well, could I become the maintainer of PyOtherSide in Mer then ? ;-)
10:37:43 <lbt> I see no real issue in having pyotherside maintained outside jolla - you just need to identify what other systems depend on it and collaborate with them
10:37:47 <M4rtinK> I do maintain it in Fedora already
10:38:00 <lbt> M4rtinK: I think that's a reasonable request
10:38:39 <lbt> Mer obviously cares about downstream a huge amount
10:39:03 <lbt> so you'd have to talk to downstream (jolla) about things like the Store
10:39:09 <M4rtinK> yeah
10:39:29 <lbt> that is probably the biggest immediate stumbling block to saying "just do it"
10:39:42 <M4rtinK> I think it's not really apparent how this should work but I think things can be worked out
10:39:43 <lbt> veskuh: would you agree with all ^^ ? any comments ?
10:40:51 <veskuh> Yeah, in general I agree. And we discussed about the pyotherside update already earlier. If that goes fine, we know the process how the udpates for that would work and M4rtinK would be good maintainer.
10:41:51 <veskuh> And obviously also do agree the points that process should be easier and documented better
10:42:26 <pavi[m]> The point about mer caring about downstream should be put in "info"
10:43:11 <lbt> *nod* Maintainers have a huge responsibility for talking to downstream (even if they're a bit non-responsive sometimes!!!)
10:43:13 <locusf> FYI: I don't mind this getting sidetracked to PyOtherside :)
10:43:41 <lbt> haha
10:43:44 <M4rtinK> this is probably another side effect of Mer/Sailfish OS basically combining a community & enterprise distro into one
10:43:56 <Jaymzz_> #info If pyotherside update goes fine, we will know the process for how the updates will be handled. M4tinK would be a good maintainer. the process should be easier and documented better.
10:44:03 <lbt> subtle - and a good point locusf - lets link it back too
10:44:21 <M4rtinK> but that's what we have now and have to work with it :)
10:44:37 <lbt> locusf: I think mer:next is a bad idea - but mer:nemo is probably a good idea
10:44:59 <lbt> and locusf you could accept pyotherside into mer:nemo with a lot less risk
10:45:10 <locusf> this is good discussion, if nemo can somehow help with all the community testing (given volunteers) by all means
10:45:18 <locusf> lbt: indeed I agree
10:45:19 <lbt> that would work if mer:nemo was kept as close as possible to mer:core for jolla
10:45:41 <lbt> so nemo would have to have quite a conservative view
10:46:45 <lbt> (well, it would if it were to be useful in that respect which is I think what's being suggested)
10:48:03 <locusf> conservative meaning being close to mer:core but still admissioning patches for upstream updates to some degree?
10:48:55 <lbt> locusf: yes - and having "be a realistic early adoption model for sfos" as a goal
10:49:02 * M4rtinK_phone_ is switching to phone now
10:49:02 <sledges> if it becomes not conservative enough, we might hit chriadam_'s problem (Requires directives in .spec files)
10:49:45 <lbt> sledges: and also if nemo starts replacing lipstick etc etc... then that's just not going to happen
10:50:10 <lbt> so it has to be something that sfos direction wants to use as a trial area
10:50:23 <locusf_> it seems that matrix lags behind quite a lot so I'll cchange to this nick
10:50:39 <Jaymzz_> Just a heads up, there is less than 15 minutes left of the proposed 60 minutes.
10:51:07 <locusf_> lbt: +1
10:51:45 <lbt> I think we need some input from jolla on that goal too - but maybe the community should produce a proposal to allow discussion around it?
10:52:24 <sledges> and what if community wants a bleeding edge option of many packages, e.g. mer:breakthingstomakethings ?
10:52:26 <M4rtinK_phone_> BTW, if stuff like Flatpak happens for app distribution
10:52:52 <M4rtinK_phone_> this all should become quite a bit easier
10:52:56 <lbt> sledges: then that's not nemo ??
10:53:52 <lbt> sledges: I think that goal is just not compatible - there'd have to be a new project. I think in many ways that's what nemo used to be
10:54:08 <lbt> but overall lack of resource means it isn't viable (yet)
10:54:39 <lbt> this way we bring community contributions back to SFOS and re-kindle jolla's community presence too
10:54:44 <pavi[m]> Its really an important topic. Put in TJC as wiki post?
10:55:01 <lbt> nb this all depends on open sourcing progress too ....
10:55:08 <sledges> yes, and even such things like toolchain upgrade could be achieved via mer:nemo
10:55:16 <sledges> (via mer:<feature> as stage 1?)
10:55:17 * lbt looks at mer:core:gcc53 and mer:core:gcc61 too
10:55:46 <lbt> I almost said that 2 mins ago - hence in cut buffer :D :D
10:56:50 <sledges> aha!
10:56:59 <sledges> #link https://build.merproject.org/package/show/mer:core:gcc53/gcc5
10:57:05 <sledges> to track progress ;) well done abranson!
10:57:10 <Jaymzz_> 8 minutes remaining :)
10:58:16 <lbt> so ... any actions ?
10:58:38 <sledges> create mer:nemo? :)
10:59:04 <sledges> i wonder if it could be created as feature project (linked to mer:core)
10:59:36 <lbt> sledges: I'd like to see a proposal first
10:59:46 <lbt> and discuss naming, goals, bugs etc
10:59:54 <sledges> locusf_: ^
10:59:56 <abranson> sledges: yeah didn't get very far with that as yet...
10:59:57 <locusf_> aye
11:00:16 <lbt> locusf_: want to take the action to pull up a proposal
11:00:25 <locusf_> lbt: yes
11:00:41 <Jaymzz_> 5 minutes :) Are we wrapped up...almost? :D
11:01:25 <locusf_> #action locusf to create proposal for further discussion leading to nemo being as staging for sailfish
11:01:26 <lbt> #action locusf_ to pull together a proposal to cover mer:nemo (tbc), feature projects/bugs and the goal of nemo in supporting sfos. Eventually to be reviewed and responded to by Jolla management.
11:01:30 <locusf_> heh
11:01:41 <Jaymzz_> that was cool :D
11:02:12 <pavi[m]> Jaymzz:  announcement?
11:02:13 <sledges> abranson: important is to make the first step;)
11:02:16 * lbt drops a side-action on jolla too ;)
11:02:30 <Jaymzz_> locusf_: So do you think we are ready to move on? :)
11:02:36 <locusf_> Jaymzz_: yes
11:02:50 <Jaymzz_> Awesome! Great discussion there guys :)
11:03:06 <Jaymzz_> #topic General discussion (15 min)
11:03:56 <pavi[m]> When is Jala phone coming up?
11:04:24 <Jaymzz_> So, does anyone think we should make Xperia discussion that we had today a pinned topic for future meetings as c-la_ was  proposing?
11:05:11 <c-la_> Jaymzz_: me ?
11:05:18 <nh1402> NFC support in Sailfish, Sony now being a partner of sorts with Jolla and also being one of the founding members of the NFC forum along with NXP and Nokia I believe, and a large quantity of ported devices supporting it. Shouldn't it be about time that it's supported in Sailfish?
11:05:47 <kimmoli> yes
11:05:48 <c-la_> Jaymzz_: thanks for pinging
11:06:14 <pavi[m]> Coming to Xperia question. Will the camera in SFOS be as good as the Android one?
11:06:28 <Jaymzz_> c-la_: Yeah wasn't it you who proposed this up there? or am I mistaken?
11:06:47 <pavi[m]> Jaymzz:  it was him dont worry
11:07:18 <c-la_> Jaymzz_: yes I proposed it
11:07:20 <c-la_> :)
11:08:02 <Jaymzz_> pavi[m]: So as Veskuh said above during the discussion, "For the camera, we cannot yet promise that all the features of the camera are supported, but we are working on it and we think that we are going to get great quality pictures out of the camera."
11:08:26 <veskuh> pavi[m]: At the moment Jala schedule looks like 2H/2017
11:09:11 <pavi[m]> Ahh nice.
11:10:18 <Jaymzz_> c-la_: I can make the Xperia topic a pinned one by the end of each meeting just like general discussion and depending on how much news we are going to have regaridng the topic, I can give it duration accordingly. If we had nothing new to provide, I can simply say in my reminder email that we won't be talking about it. What do you say?
11:10:39 <veskuh> pavi[m]: For the Sony camera app on Android they have bunch of stuff like filters, effects etc in there. Those we don’t have. For the camera driver, we are not yet 100% what we can have fully supported, but in anycase the picture quality is far better than what we’ve had before.
11:11:03 <r0kk3rz> Jaymzz_: no need to make it pinned, im sure there will be announcements and blog posts about it anyway :)
11:11:31 <pavi[m]> veskuh:  yeah I was exactly asking about it. Also sony uses lot of propreitary optimisations to make the picture look better. Will the opensource project get them?
11:11:35 <c-la_> Jaymzz_: fine for me, thanks
11:11:35 <nh1402> what about the NFC situation, I would like to pass through NFC for sfdroid uses.
11:11:44 <Jaymzz_> r0kk3rz: Alright as you wish, so in that case, if anyone had extra questions, just make a 5-10 min topic and ask it here or ask it on the blog.
11:12:01 <Jaymzz_> c-la_: Which one is fine for you? The one I said or r0kk3rz?
11:12:04 <r0kk3rz> veskuh: sony also have some rather good image processing algorithms that they wipe off the phone when you unlock the bootloader. it would be awesome to get those :)
11:12:37 <r0kk3rz> but thats a rather big wish
11:12:50 <veskuh> pavi[m]: r0kk3rz Yeah, we’re aware of these, I don’t have more details I can say at this point.
11:12:52 <nh1402> r0kk3rz: I've found most other phones with Sony sensors have better image quality than Sony themselves
11:13:18 <c-la_> Jaymzz_: yours, but either is fine in the end
11:13:27 <pavi[m]> r0kk3rz:  Yeah was asking about those image processing algorithms. So we wont be getting them I guess in opensource project of Sony.
11:13:30 <r0kk3rz> nh1402: the sensor is only one small part of the equation
11:14:07 <Jaymzz_> c-la_: Alright, r0kk3rz' solution was more practical. In case anyone has extra questions, ask it. And of course, we will do our best to keep you updated on the progress.
11:14:40 <c-la_> +1
11:14:55 <r0kk3rz> Jaymzz_: blog post interview with Alin Jerplea kgo!
11:16:07 <Jaymzz_> r0kk3rz: That might be a very interesting idea actually! I'll get in touch to see if we can take this further! Thanks for the idea
11:16:57 <pavi[m]> Is there a plan to improve the app gap situation. Can jolla afford to organise app devel workshops?
11:17:07 <nh1402> Jaymzz_: i have
11:17:28 <sledges> nh1402: sfdroid should just use android's guts for NFC
11:17:34 <Jaymzz_> nh1402: What do you have mate?
11:18:21 <Jaymzz_> #action Jaymzz to discuss some collaboration possibilities with Alin Jerplea
11:19:11 <Jaymzz_> we have about a minute left guys
11:19:12 <sledges> pavi[m]: Maemi Regatta brought awesome apps
11:19:16 <Jaymzz_> gonna move on soon
11:19:19 <sledges> *Maemo
11:19:25 <eekkelund> Yay
11:19:36 <sledges> the winner himself^ ;)
11:20:07 <pavi[m]> sledges:  I agree Maemo regatta is cool. Is there a chance of Jolla replicating it in larger scale?
11:20:18 <nh1402> Jaymzz_: native NFC support in Sailfish
11:20:40 <veskuh> pavi[m]: I think this was discussed in the last community meeting as well. There is couple of things going on 1) OMP is promoting Sailfish development in russia 2) New devices will help  - Jala, inoi, Xperia 3) New china partner will hopefully promote similarly in china
11:20:45 <pavi[m]> Jolla official tweeted about Maemo Regatta. But something more official so that russian devs and others get to participate. We also have latin america phone coming up.
11:20:51 <Jaymzz_> Veskuh can you answer the NFC question by nh1402 please? :)
11:21:33 <M4rtinK_phone_> sign me in for another competition! :-)
11:21:52 <pavi[m]> veskuh:  New devices will get new users but before the devices get released a nice workshop or something in target country and its apps would be cool.
11:21:54 <sledges> M4rtinK_phone_: what prize would make you interested?;)
11:22:02 <nh1402> Sony now being a partner, and one of the first to bring NFC, I thought it would be about time Sailfish supports it at natively, or at the very least for the Xperia devices.
11:22:06 * M4rtinK_phone_ = app updates category 2nd place
11:22:53 <Jaymzz_> Just FYI I'm giving extra time to this topic in order to get all the questions answered
11:23:02 <M4rtinK_phone_> nh1402: Sailfish OS running Xperia would be nice :)
11:23:19 <M4rtinK_phone_> would have use for that ;-)
11:23:43 <Jaymzz_> #info There is couple of things going on 1) OMP is promoting Sailfish development in russia 2) New devices will help  - Jala, inoi, Xperia 3) New china partner will hopefully promote similarly in china
11:23:58 <nh1402> I don't like the fact that out of all the sensors and camera's and stuff, the one thing that still isn't supported is NFC
11:24:58 <nh1402> Another thing to note is dual cameras are starting to become a thing, how are Jolla going to handle that?
11:25:24 <sledges> #info The question to the above answer was: Is there a plan to improve the app gap situation. Can jolla afford to organise app devel workshops?
11:25:38 <veskuh> Proper NFC support with useful set of usecases is still a roadmap item and I can’t promise a schedule for it at this point.
11:25:40 <r0kk3rz> nh1402: what would you want to do with it?
11:26:16 <Jaymzz_> #info Question about NFC situation for Xperia devices and Sailfish OS in general
11:26:18 <nh1402> r0kk3rz: I would like to try and get NFC payment apps working in sfdroid
11:26:23 <veskuh> Having simple HW enabler is smaller item, but things like audio routing, payment, support in Dalvik are bigger items.
11:26:26 <Jaymzz_> #info Answer: Proper NFC support with useful set of usecases is still a roadmap item and I can’t promise a schedule for it at this point.
11:26:47 <Jaymzz_> #info Having simple HW enabler is smaller item, but things like audio routing, payment, support in Dalvik are bigger items.
11:27:05 <sledges> nh1402: can you not simply use android's nfc mw for that?
11:27:10 <sledges> in sfdroid's context
11:27:16 <sledges> no need for sfos to be aware of it
11:27:17 <nh1402> also basic things, like reading a tag to snooze/dismiss alarms, IoT related things and what have you.
11:27:40 <nh1402> sledges: I could but if everything else is being passed through from Sailfish, its best if everything is.
11:27:59 <sledges> nfc is being passed from actual nfc tag (hw)
11:28:02 <r0kk3rz> wrapping the android nfc interface to the qt one should be straight forward
11:28:08 <pavi[m]> nh1402:  Yeah good ideas with NFC. Lets hope it gets supported.
11:28:50 <Jaymzz_> Alright guys we are way over time now, let's make NFC a new topic for the next meeting, okay? nh1402
11:29:18 <sledges> with separate usecases: sfdroid, aliendalvik, sfos (no apps in sfos case?)
11:29:40 <r0kk3rz> sledges: build it and they will come!
11:29:53 <r0kk3rz> you can do some coolish things with just ndef text record tags for instance
11:30:02 <sledges> i've enlisted in the order of the lowest hanging fruits;)
11:30:08 <Jaymzz_> I'm going to move on in less than a minute, I think this deserves its own topic and should be proposed for the next meeting.
11:30:21 <nh1402> Jaymzz_: no need really, veskuh answered already, but if people want to discuss in more detail in the next meeting, sure.
11:30:33 <Jaymzz_> Alright let's see then :)
11:30:36 <Jaymzz_> Moving on
11:30:39 <Jaymzz_> #topic Next meeting time and date (5min)
11:31:06 <Jaymzz_> I propose Wednesday 5th of April, 09:00 UTC. Votes?
11:32:22 <Jaymzz_> Right, seriously, anyone? :D
11:32:33 <veskuh> ok for me
11:32:38 <nh1402> I'm not sure which way to take the silence, is that a unanimous agreement or disagreement
11:32:38 <r0kk3rz> make it so
11:32:48 <sledges> silence means consent
11:33:11 <nh1402> I see it that way but not to everyone
11:33:14 <r0kk3rz> speak now or forever hold your peace
11:33:18 <Jaymzz_> Alright I'll take it as consent then ;)
11:33:42 <nh1402> 2 weeks on Wednesday it is then, providing there are enough topics.
11:33:57 <Jaymzz_> #info Next meeting will be held on 5th of April 2017 at 09:00 UTC
11:34:31 <Jaymzz_> nh1402: I'll hold the meeting anyway in case anyone wants to discuss. I'll try my best not to postpone meetings anymore to keep engaging with the community, thanks to LarstiQ
11:34:42 <pavi[m]> Thank your everyone. I enjoyed the conversation. Its the first time I asked my topic 😃
11:35:24 <Jaymzz_> So it is conformed guys, thank you everyone for this long and productive conversation! Meeting minutes will be sent to you via email. Take care and bye for now.
11:35:27 <r0kk3rz> nh1402: good news, with the qt5.6 upgrade we get qtnfc api, which supports this backend https://01.org/linux-nfchttps://01.org/linux-nfc
11:35:28 <veskuh> thanks
11:35:32 <Jaymzz_> #endmeeting