15:00:09 <cybette> #startmeeting SailfishOS, open source, collaboration: 4-November @ 15:00 UTC
15:00:09 <Merbot> Meeting started Tue Nov  4 15:00:09 2014 UTC.  The chair is cybette. Information about MeetBot at http://wiki.merproject.org/wiki/Meetings.
15:00:09 <Merbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:19 <cybette> #info Welcome to another week of SailfishOS OSS and collaboration meeting
15:00:26 <cybette> #info Meeting info and agenda: http://lists.sailfishos.org/pipermail/devel/2014-November/005161.html
15:00:33 <cybette> I'm the meeting chair for today and will be keeping time and order. Please behave and show mutual respect, and let's have a productive discussion!
15:00:38 <cybette> #topic Brief introductions (5 min), prefix your information with #info
15:00:41 <sledges> #info Simonas Leleiva community sailor; sailfishos for everyone
15:00:50 <cybette> #info Carol Chen, Community bunny at Jolla, hatless chair today and hopping excitedly about #TOHKBD
15:00:52 <kimmoli> #info Kimmo Lindholm - toh tailor (prooudly member of tohkbd team)
15:01:06 <r0kk3rz> #info Lewis Rockliffe - app developer
15:01:09 <lbt> #info David Greaves, Mer guy and sailor
15:01:16 <situ> #info Siteshwar, community
15:01:22 <reviewjolla> #info Simo Ruoho, active at Review Jolla and TJC, community member
15:01:25 <mattaustin> #info Matt Austin - app developer / community
15:01:27 <Stskeeps> #info Carsten Munk, Chief Research Engineer @ Jolla
15:01:30 <SK_work> #info Lucien, community
15:01:36 <lainwir3d> #info Richard Rondu, community
15:01:37 <eleroux> #info Eric Le Roux, Bugzilla + TJC admin @ Jolla
15:01:49 <stephg> #info Steph Gosling, community
15:01:58 <daitheflu> #info François, community
15:02:11 <locusf> #info Aleksi Suomalainen, community
15:02:30 <ernesti> #info Erik Veijola, Sailor
15:03:47 <Armadillo> #info Thomas Amler, app developer
15:03:57 <cybette> introduce yourself with prefix #info if you've just joined!
15:04:20 <sledges> hey dpurgin ! o/
15:04:26 <tbr> #info Thomas Ruecker, community member
15:04:33 <dpurgin> #info Dmitriy Purgin, Qt professional, SailfishOS enthusiast
15:04:48 <sledges> (and callrecorder creator ;P)
15:04:53 <dpurgin> hi all
15:04:57 <dpurgin> yep, he's right :D
15:05:13 <cybette> all right! thanks for all the intros :)
15:05:18 <cybette> first topic..
15:05:22 <iekku> #info iekku pylkk�, developer community
15:05:23 <M4rtinK> #info Martin Kolman, modRana developer, community
15:05:27 <cybette> #topic TJC: HOT Topics of the week/month - simo / reviewjolla (15 min)
15:05:34 <reviewjolla> Hi all, my first time in this meeting. Great to see such activity! Ok, the intro for the subject coming up:
15:05:35 <cybette> #info To gain activity and outcome in the issues currently under development by Jolla/Sailfish ppl on TJC questions, we could discuss if it would be useful to lift a set of topics as "hot" for a selected time period, and get the community to gather around these topics considering the next system update
15:05:48 <reviewjolla> I'm a bit worried about the amount of questions there, so I'm bringing up two ideas to this board. I hope we can decide on these, and use the rest of 15mins to discuss any other further actions to make TJC even more useful to all parties.
15:06:05 <reviewjolla> Actions so far: help page, info when adding a new question, guideline posts, cleaning up together -post, new moderators from community side (chemist, tbr), several actions of single users
15:06:19 <reviewjolla> Current situation: 7954 questions (60% of them unanswered). 100 new questions during the past week. Important new q's vanish quickly into the mass before getting votes. Some users give an "up" to their posts because of this, adding the mess.
15:06:55 <reviewjolla> And to my 1st idea: 10-50 q:s (maybe under current developement at Jolla?) are picked as "hot questions of the week/month" and linked to one q. This q is kept on top and has a reserved tag "HOT". Users are asked to vote/comment especially on linked q's, common goal as all the selected q:s can be closed after the week/month has passed, and the post can be updated with new q:s
15:08:09 <cybette> reviewjolla: so like a pined post to feature a selected group of qns each week/month/some-time-period?
15:08:17 <cybette> *pinned post
15:08:31 <reviewjolla> smthng like that, yes
15:08:42 <eleroux> reviewjolla: how would this list of posts be maintained? And who would it?
15:08:45 <cybette> who picks the post?
15:08:54 <reviewjolla> That's to be decided
15:09:28 <reviewjolla> I'd suggest that Jolla gives the subjects, anyone of the moderators picks the posts that goes along with those
15:11:12 <tbr> I think an algorithm that emphasizes new question votes stronger for the default view could help
15:11:21 <reviewjolla> but maybe, before going into the details, is the idea generally worth some talk here?
15:11:39 <tbr> that way questions that e.g. pick up votes quickly get scored high
15:11:48 <eleroux> reviewjolla: it's a good topic IMHO
15:12:01 <ernesti> +1
15:12:07 <cybette> yes I think this topic deserves some attention
15:12:26 <leszek> nice idea
15:12:37 <reviewjolla> thanks for all :) Into the details then
15:12:48 <eleroux> There was some discussions about enabling some kind of sticky posts earlier though we haven't have time to do anything related
15:13:13 <reviewjolla> So, Jolla could give just like the keyword, e.g. what their working with during the next month, to the mods
15:13:35 <Morpog_Jolla_> i think it's a good idea
15:13:38 <reviewjolla> mods would pick up 10-50 q:s to one post, and that post would be promoted as HOT?
15:13:48 <eleroux> so your idea is to have a prominent selection of questions/topics, visually in the UI too, correct?
15:14:19 <reviewjolla> like a wiki list of q:s under discussion, gathered to one q
15:14:28 <sledges> reviewjolla: bijjal already sends iteration plans every month to sailfish-devel
15:14:28 <Morpog_Jolla_> at least for that collection topic eleroux
15:15:36 <reviewjolla> Any other ideas for implementing this?
15:15:45 <cybette> #info Possibilty of "hot/sticky" post to bring attention to selected questions over a time period. to be considered: picked by who, perhaps moderators?
15:16:06 <r0kk3rz> having a way to seperate ideas\feature-requests from rants\bugs\compaints\duplicates would be nice too
15:16:06 <reviewjolla> moderators + active volunteers?
15:16:10 <cybette> #info an algorithm that emphasizes new question votes stronger for the default view could help
15:16:18 <tbr> thanks :)
15:16:23 <reviewjolla> :)
15:16:48 <cybette> #info bijjal sends iteration plans every month to sailfish-devel mailing list - can be used as source for post selection
15:17:04 <sledges> thanks :)
15:17:32 <reviewjolla> I think I'll post my 2nd idea: In the next newsletter from Jolla, users are kindly asked to go through their own questions and check if there are any worth updating/closing/removing. This request should be asked politely, and explain the situation why it's asked, messaging to the users that their q's matter, and Jolla want's the portal cleaner so that the most important q:s gets their deserved position in the forum.
15:18:37 <cybette> it would be nice to do a spring-cleaning of posts and definitely helps when everyone participates :)
15:18:57 <eleroux> cybette: +1
15:19:08 <reviewjolla> spring-cleaning sounds like a nice topic for the newsletter :)
15:19:38 <kimmoli> in november ?
15:19:39 <cybette> #info suggestion for Jolla to send out some kind of newsletter for a DIT (do it together) spring cleaning of TJC posts
15:19:54 <eleroux> note that most active users have enough creds to do some clean.up, and they actually do
15:20:05 <cybette> we have one minute left on topic. should I ask for the discussion to continue on TJC ;) ;)
15:20:07 <reviewjolla> well, let's leave it to the newsletter team to find out the best timing and topic for that?
15:20:08 <r0kk3rz> having not so important questions in the archive is good though
15:20:24 <reviewjolla> decisions? And thanks
15:20:41 <eleroux> r0kk3rz: the questions remain they're juste closed
15:21:13 <M4rtinK> would be nice to get some feedback from Jolla as part of the cleanup :)
15:21:26 <cybette> I think we need a place to continue this discussion -> TJC?
15:21:38 <cybette> M4rtinK: certainly. and I will ping Jolla sailors to do so
15:21:39 <M4rtinK> even WONTFIX or NOTABUG would be nice sometimes :)
15:21:43 <eleroux> reviewjolla: for 1st idea, go ahead and build the hot topic, I'll add a dedicated tag and see how we can visually make it prominent
15:22:22 <eleroux> cybette: let's give it a shot ^^, approved :p
15:22:27 <cybette> #action reviewjolla to build hopt topic for first idea, eleroux will add a dedicated tag and see how to make it visually prominent
15:22:31 <reviewjolla> as soon as I receive the keywords, yep, I can put up the first hot
15:22:37 <eleroux> cybette: thanks :D
15:22:50 <eleroux> as a wikipost
15:22:56 <reviewjolla> yep
15:23:03 <cybette> #action reviewjolla to start a discussion on TJC about "spring-cleaning" TJC, cybette to ping Jolla sailors to provide feedback as well
15:23:06 <eleroux> cool, thanks reviewjolla!
15:23:20 <reviewjolla> thanks for the discussion, on to the next then
15:23:22 <cybette> good discussion. thanks! and we have some actions too. let's continue..
15:23:29 <cybette> #topic Quick update on python/pyotherside dependant apps in Jolla Harbour - mattaustin (10 min)
15:23:37 <cybette> #info Does the store client now support apps for specific versions of Sailfish OS? It appeared that the Jolla 'utilities' app was conditionally available for users of Update 9 only (although it did appear as an auto-suggestion when searching the store on Update 8, app details could only be viewed on Update 9).
15:23:42 <cybette> #info Does this mean the framework is now in place to permit python/pyotherside apps? If not, do we have a revised ETA?
15:24:06 <cybette> mattaustin: please take the lead now, thanks :)
15:24:19 <mattaustin> Hi all - pretty self-explanatory in the topic - just wondering if there is any news/updates regarding this for us developers?
15:24:50 <tbr> I guess the obvious question is: is thp in the house and can he give a statement?
15:26:04 <mattaustin> (on a related note, the python-support branch of rpmvalidator only appears to allow pyotherside 1.0, will 1.2 be allowed (in the repos on newer updates)?
15:26:36 <sledges> I rememeber someone else than thp mentioning that it will land in an update (don't want to run `git blame` here though:)
15:26:45 <M4rtinK> I hope so - 1.0 is pretty much obsolete
15:27:34 <mattaustin> My understanding when we last discussed, was that the harbour server had received the required updates for app/sailfish version matching, but the store client needed work.
15:27:48 <cybette> I can't comment on the python stuff but store versioning is in the works currently, some issues still need fixing and no ETA yet (afaik)
15:28:36 <mattaustin> Thanks, no worries - will continue to wait eagerly :)
15:29:26 <M4rtinK> taking a bit too long though ;-)
15:29:40 <cybette> #info work is ongoing, but not enough info available to provide an update or ETA at this time.
15:30:01 <SK_work> multiversion for store would be needed as the new SDK canoot create binaries for old firmwares
15:30:43 <r0kk3rz> surely its in the plan for U10 release?
15:30:45 <sledges> SK_work: another reason for opt-in:)
15:30:53 <SK_work> sledges: indeed
15:31:02 <sledges> r0kk3rz: i guess no other choice there:D
15:31:11 <cybette> #action cybette will poke around internaly and try to get more satisfying answers for next meeting
15:31:26 <cybette> ok one hot topic coming up..
15:31:34 <mattaustin> Thanks!
15:31:37 <sledges> tag:hot
15:31:39 <cybette> #topic Scheduling for future meetings: weekly/fortnightly? fixed/rotating time? - all (10 min)
15:31:43 <cybette> sledges: :D
15:31:55 <iekku> :D
15:32:04 <cybette> so we've continuously had debates about what's the "best" time for these meetings
15:32:05 <iekku> umh, i missed most of the meeting
15:32:13 <tbr> I've motioned before, that having meetings at 10:00 UTC hasn't proved to be useful
15:32:16 * cybette assigns all her actions to iekku
15:32:26 <sledges> :D
15:32:28 <iekku> :D i can take the last one
15:32:46 <cybette> iekku: thanks! ok let's get back to topic
15:32:55 <iekku> and make sure i don't have next time any overlapping meetings
15:33:14 <cybette> tbr: your proposal is then to always have it at 15 UTC?
15:33:31 <iekku> 15 UTC works better for me during winter
15:33:52 <tbr> cybette: unless there are good reasons brought up
15:34:31 <tbr> cybette: I have asked and also observed and it doesn't seem that e.g. the intended audience of the 10:00 meetings would use that opportunity
15:35:00 <cybette> it might be futile to ask if 15 UTC is good for everyone here since, well, everyone is here @ 15 UTC :)
15:35:04 <iekku> tbr, during summer time it was hard to get sailors in the meeting. so..
15:35:15 <cybette> it seems we have a good turn out today
15:35:24 <kimmoli> UTC 15 works best for me too, maybe UTC 14 during summer time...
15:35:30 <iekku> kimmoli, +1
15:35:46 <reviewjolla> -1 for always the same time. Not nice for ppl in The Other Half of the globe
15:36:16 <tbr> iekku: it was also meant for community members from the timezones around australia and hong kong
15:36:20 <iekku> reviewjolla, that's why we have tried to makerotation
15:36:21 <sledges> kimmoli: that's still the same hour due to DST ;)
15:36:51 <tbr> reviewjolla: have you noticed that they don't seem to be interested? it's a significant inconvenience for people on this side, while the others don't come.
15:36:52 <kimmoli> sledges: ? this was at 18:00 EEST in summer, now 17:00 EEST
15:37:11 <dpurgin> afaik UTC does not observe DST
15:37:20 <tbr> correct
15:37:20 <cybette> how about this, 15 UTC by default (we can discuss summer when it comes around again, might be a while), and a different time if for example someone really wants to lead a discussion on a topic but can't make it at 15 UTC
15:37:37 <reviewjolla> maybe just tune up the time of the not_so_popular meeting time? this 15UTC seems nice
15:37:48 <r0kk3rz> +1 cybette
15:38:01 <mattaustin> 15UTC just about works for me here in Western Australia, but if there is anyone over East then it would be around 2am local time.
15:38:01 <cybette> it will be impossible to find a time to fit everyone, every time zone etc. we have to consider the majority of the *active* community members
15:38:02 <dpurgin> I agree, there's no point to hold meetings for people from Australia if there are none :)
15:38:04 <daitheflu> +1 cybette
15:38:04 <iekku> +1 cybette
15:38:06 <kimmoli> +1 (when suggesting topic, can suggest different time)
15:38:11 <ernesti> +1
15:38:25 <iekku> and +1 for kimmoli
15:38:31 <reviewjolla> +1 for kimmoli
15:38:32 <iekku> mattaustin, :nod:
15:38:42 <cybette> mattaustin: good to hear!
15:38:45 <M4rtinK> +1
15:38:58 <tbr> cybette: we can of course have a TJC item where answers are times and people vote for them
15:39:06 <tbr> cybette: that would get us at least an indication
15:39:19 * kimmoli has experience in turning people in australia to finnish time...
15:39:26 <r0kk3rz> good thing im not going back to hobart :)
15:39:41 <mattaustin> :)
15:39:43 <cybette> tbr: like for all different times and let people figh...vote it out?
15:40:07 <dpurgin> we could ask people in mailing list to reply and ask for time change when notifying about a meeting
15:40:18 <tbr> cybette: sort of, it would give at least an idea what people want. don't promise to have the meetings at those times, that would just disappoint.
15:40:38 <r0kk3rz> for now keep it the same, people can nominate representatives if they cannot attend
15:40:39 <sledges> dpurgin: it's more like https://together.jolla.com/question/54157/sailfishos-open-source-collaboration-meeting-planning/#post-id-59697
15:40:58 <tbr> dpurgin: on the mailing list it will be a flame fest :) I think we did that already
15:41:01 <cybette> ok it will be interesting to see the preference - just need to get people to vote :)
15:41:17 <tbr> cybette: mention it in the invitation
15:41:26 <dpurgin> okay, it just shows I don't visit TJC much :D
15:41:28 <tbr> and the minutes
15:41:29 <tbr> etc
15:41:38 <reviewjolla> cybette: link to the voting to the inv.
15:41:59 <cybette> #agreed meetings at 15 UTC, but allow for exceptions e.g. someone writes in with topic proposal and new proposed time
15:42:54 <cybette> #action start a poll on TJC for time preferences to get a better idea going forward, link it to the meeting invitation
15:43:10 <kimmoli> trending-hot-topic: next meeting schedule \o/
15:43:14 <cybette> sounds good?
15:43:16 <cybette> kimmoli: :D
15:43:36 <tbr> hehe
15:43:39 <cybette> ok now we can decide on...
15:43:43 <cybette> #topic Wrap up and next meeting (5 min)
15:44:19 <iekku> 2 weeks from now?
15:44:24 <ernesti> +1
15:44:36 <tbr> +1
15:45:23 <iekku> hmmm, 2 weeks from now is slush
15:45:24 <stephg> +1
15:45:28 <stephg> oh
15:45:30 <leszek> +1
15:45:54 <iekku> i'm not sure how many sailors / finland based community members are participating
15:45:55 <leszek> then maybe a week after
15:45:58 <sledges> +1
15:46:21 <iekku> so 25th ?
15:46:39 <cybette> yes we will be busier than usual these couple of weeks so can we have it on 25th?
15:46:43 <cybette> +1 iekku
15:46:51 <ernesti> +1 on 25th
15:46:59 <leszek> +1 25th
15:47:36 <stephg> well it's dependent upon topics also
15:48:11 <iekku> let's make sure there is topics :)
15:48:16 <cybette> stephg: true, and we'll work to bring you more answers and news and fun and christmas cheer :)
15:48:29 <r0kk3rz> maybe we need to integrate the 'hot topics' and the meeting topics
15:48:47 <cybette> ok so let's make it 25th, 15 utc. chair? i can do it if i kinda ignore the hat part :P
15:49:21 <cybette> i'll take it for now, but volunteers welcome
15:49:36 <cybette> #info Next meeting Tues Nov-25 @ 15:00 UTC, Chairperson cybette
15:50:01 <cybette> if nothing else, thanks for a great meeting!
15:50:05 <kimmoli> (remeber topic)
15:50:13 <kimmoli> and friendly reminder: https://www.kickstarter.com/projects/2028347278/tohkbd-the-other-half-keyboard-for-your-jolla
15:50:18 <cybette> yes!!
15:50:30 <SK_work> :)
15:50:35 <sledges> so awesome:)
15:50:36 <cybette> #info Check out today's HOT TOPIC: https://www.kickstarter.com/projects/2028347278/tohkbd-the-other-half-keyboard-for-your-jolla
15:50:40 <SK_work> :)
15:50:40 <kimmoli> damn slush is expensive to attend...
15:50:41 <iekku> wow, almost 40k
15:50:53 <cybette> cheers
15:50:55 <cybette> #endmeeting